BAEKJOON - 10828 스택

BAEKJOON - 10828 스택

BAEKJOON - 10828 스택

Task description#

원문 : 백준 10828 링크

정수를 저장하는 스택을 구현한 다음, 입력으로 주어지는 명령을 처리하는 프로그램을 작성하시오.

명령은 총 다섯 가지이다.

push X: 정수 X를 스택에 넣는 연산이다. pop: 스택에서 가장 위에 있는 정수를 빼고, 그 수를 출력한다. 만약 스택에 들어있는 정수가 없는 경우에는 -1을 출력한다. size: 스택에 들어있는 정수의 개수를 출력한다. empty: 스택이 비어있으면 1, 아니면 0을 출력한다. top: 스택의 가장 위에 있는 정수를 출력한다. 만약 스택에 들어있는 정수가 없는 경우에는 -1을 출력한다.

Condition#

  • 첫째 줄에 주어지는 명령의 수 N (1 ≤ N ≤ 10,000)이 주어진다. 둘째 줄부터 N개의 줄에는 명령이 하나씩 주어진다. 주어지는 정수는 1보다 크거나 같고, 100,000보다 작거나 같다. 문제에 나와있지 않은 명령이 주어지는 경우는 없다.
  • 출력해야하는 명령이 주어질 때마다, 한 줄에 하나씩 출력한다.

input output#

14
push 1
push 2
top
size
empty
pop
pop
pop
size
empty
pop
push 3
empty
top
예제 출력 1 복사
2
2
0
2
1
-1
0
1
-1
0
3
예제 입력 2 복사
7
pop
top
push 123
top
pop
top
pop
예제 출력 2 복사
-1
-1
123
123
-1
-1

Solution#

import sys

class Stack :					# 클래스 생성
	def __init__(self) :
		self.elements = []		# 스택의 엘리먼츠 추가

	def push(self, x) :		
		self.elements.append(x)	# x를 스택에 추가

	def empty(self) :			# 엘리먼츠의 길이(사이즈)가 0 이면 1 
		if len(self.elements) == 0 : 
			print(1)
			return 1
		else :
			print(0)
			return 0

	def pop(self) :			
		if len(self.elements) == 0 : #비어있는 경우 -1
			print(-1)
		else :
			self.top()
			self.elements.pop()

	def size(self) :
		print(len(self.elements))
		return len(self.elements)

	def top(self) :
		if len(self.elements) == 0 :
			print(-1)
		else :
			print(self.elements[-1])


#n = int(input())
n = int(sys.stdin.readline().rstrip())
s = Stack()

for i in range(0,n) :
	input_split = sys.stdin.readline().rstrip().split()
	command = input_split[0]
	#command = str(input())

	if 'pop' == command.lower() :
		s.pop()
	elif 'size' == command.lower() :
		s.size()
	elif 'top' == command.lower() :
		s.top()
	elif 'empty' == command.lower() :
		s.empty()
	elif 'push' == command.lower() :
		s.push(input_split[1])


TestCase#